Посчитать количество ячеек в таблице Excel, удовлетворяющих требуемому значению, можно с помощью функции СЧЁТЕСЛИ. Работа функции напоминает работу фильтра – она считает все, что попадает под заданное условие.

Синтаксис функции:

=СЧЁТЕСЛИ(диапазон поиска; критерий поиска)

Функция считает, сколько ячеек удовлетворяют критерию поиска

На примере таблицы ниже (Рис.1) опишу основные способы применения функции.

Рис.1. Таблица для примера

Рис.1. Таблица для примера

Примеры использования:

Формула Описание
1 =СЧЁТЕСЛИ(D2:D19; D2) Посчитает количество значений в диапазоне D2:D19 (Фрукты), у которых значение ячейки равно D2 (Яблоки)
2 =СЧЁТЕСЛИ(E2:E19;">20") Посчитает количество ячеек E2:E19 (Стоимость), значение которых больше 20.
3 = СЧЁТЕСЛИ($D$2:$D$19;D2) При "растягивании" по столбцу F посчитает, сколько раз каждый фрукт продали